ExludePaths does not accept a path

Jan 26, 2010 at 9:42 AM
Edited Jan 26, 2010 at 9:46 AM

I am using MbCompression on a website which is going to be maintained by a (open source) CMS; Umbraco

Because I am experiencing some script and css problems in the backend of Umbraco (inside the CMS only) I would like to exclude all the files inside the directory /umbraco.

But it seems that it is not possible to just add a path to the excludePaths element. Only direct references to files are accepted here.
Or am I just overlooking some possibility to use wildcards here like below?

<excludePaths>
   <add key="~/umbraco"/>  <!-- would exlude everything below /umbraco -->
</excludePaths>

Now it seems that I can only use filenames directly to a specific .aspx file. And because there are more than 100 different files in different directories that would be rather painfull...

Cheers, Nico

Mar 26, 2010 at 10:57 AM

Hi Nico,

Your request will not be implemented soon.

Sorry.

 

Nov 12, 2010 at 1:47 PM

Has this been implemented?

May 20, 2011 at 11:13 AM

To avoid a script or css from being processed by MbCompression, you can add to the script url a "?" and any parameter. 

For example:

Changing this:

<script type='text/javascript' src='umbraco/myscript.js'></script>

To this:

<script type='text/javascript' src='umbraco/myscript.js?ignore=yes'></script>

Will cause MbCompression to ignore this script