webresource.axd minify not working

Jul 22, 2009 at 5:21 PM

The webresource.axd files aren't minifying. The HTML source is, can't figure why the webresource.axd is not.

The server is IIS 6.0 with ASP.NET 3.5 SP1 installed. It also doesn't work via Cassini. Per the readme in the source, here's what's in my web.config:

 

<configSections>
 
<sectionGroup name="Miron.web">
   
<section name="CompressorSettings" type="Miron.Web.MbCompression.SettingsConfigSection"/>
 
</sectionGroup>
</configSections>

<Miron.web>
 
<CompressorSettings reflectionAlloweded="true" daysInCahe="10" optimizeHtml="true" compressCSS="true" compressJavaScript="true" compressPage="true" compressWebResource="true" compressThirdParityScripts="true" enabled="true">
   
<excludeTypes>
 
<add key="" />
   
</excludeTypes>
   
<excludePaths>
     
<add key="" />
   
</excludePaths>
 
</CompressorSettings>
</Miron.web>

<httpModules>
 
<add name="PageCompressionModule" type="Miron.Web.MbCompression.PageCompressionModule"/>
 
<add name="WebResourceCompressionModule" type="Miron.Web.MbCompression.WebResourceCompressionModule"/>
</httpModules>
Jul 22, 2009 at 5:29 PM

In the release version, minifing webresource.axd option is not implemented yet.

The minifing HTML option was removed in later versions.

It is recommended  to use the dll from the latest source from the 'Source Code' tab

Jul 22, 2009 at 6:51 PM

I actually compiled it from the source.

Jul 22, 2009 at 6:52 PM

I'm referring to the javascript minification

Jul 22, 2009 at 9:33 PM

You are using the latest DLL, but with old configuration.

Use the following config:

<Miron.web>
        <CompressorSettings compressCSS="true"
                            compressJavaScript="true"
                            compressPage="true"
                            compressWebResource="true"
                            minifyContent="true"
                            cachingStorage="OutputCache"
                            autoMode="true"
                            scriptsVersion="1"
                            cssVersion="1">
        </CompressorSettings>
  </Miron.web>

Jul 22, 2009 at 9:46 PM

cool, thanks.  FYI, the old config is in the README.