WebService ajax enabled

Nov 15, 2008 at 5:53 PM
Hello,

I´m trying to use this library, but I´m having problems when trying to retrieve the javascript generated by a webservice created using ajax library from .Net Framework 3.5

According to documentation to enable a webservice to be used from javascript is to add the script reference to webservice.asmx/js. It works perfect until I add the compression, MBCompression tries to compress the file, but there is no file, it is generated by the webservice.

I tried to exclude the webservice.asx/js path, but it didn´t work.

Any clue???

Thanks in advance....
Coordinator
Nov 16, 2008 at 11:18 AM
Can you supply me some code to debug the problem ?

Regards,
Miron
Nov 17, 2008 at 3:19 PM
Edited Nov 17, 2008 at 3:33 PM
Sure, I tried replaying your email, but I´m not sure if the attached file was sent.

Did you receive it?

How can I send the code to you?
Coordinator
Nov 17, 2008 at 3:38 PM

I got the attached code.

I posted a bug fix to the source control at http://www.codeplex.com/MbCompression

Let me know if it solved your problem.


Regards,

Miron

http://blog.mironabramson.com



cewongq wrote:

From: cewongq

Sure, I tried replaying your email, but I´m not sure if the attached file was sent.

Did you receive it?
Nov 17, 2008 at 3:47 PM
Another suggestion;
Instead of grouping files separate by ","; they could be group by a special tag; on this way you can add, and remove the MbCompression without any problem.
Right now if you disable MbCompression, the website cannot find the files....

On Mon, Nov 17, 2008 at 10:39 AM, Miron <notifications@codeplex.com> wrote:

From: Miron

I got the attached code.

I posted a bug fix to the source control at http://www.codeplex.com/MbCompression

Let me know if it solved your problem.


Regards,

Miron

http://blog.mironabramson.com



cewongq wrote:

From: cewongq

Sure, I tried replaying your email, but I´m not sure if the attached file was sent.

Did you receive it?

Read the full discussion online.

To add a post to this discussion, reply to this email (MbCompression@discussions.codeplex.com)

To start a new discussion for this project, email MbCompression@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Nov 17, 2008 at 3:49 PM
Another suggestion...

Instead of grouping files separate by ","; they could be group by a special tag. On this way you can add and remove the MbCompression without any problem.

Right now if you disable MbCompression, the website cannot find the files.


On Mon, Nov 17, 2008 at 10:39 AM, Miron <notifications@codeplex.com> wrote:

From: Miron

I got the attached code.

I posted a bug fix to the source control at http://www.codeplex.com/MbCompression

Let me know if it solved your problem.


Regards,

Miron

http://blog.mironabramson.com



cewongq wrote:

From: cewongq

Sure, I tried replaying your email, but I´m not sure if the attached file was sent.

Did you receive it?

Read the full discussion online.

To add a post to this discussion, reply to this email (MbCompression@discussions.codeplex.com)

To start a new discussion for this project, email MbCompression@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Coordinator
Nov 17, 2008 at 4:08 PM

Thanks for the suggestion,

But what will be the different if the separator char will be ','� or any ather char ?


Miron




cewongq wrote:

From: cewongq

Another suggestion...

Instead of grouping files separate by ","; they could be group by a special tag. On this way you can add and remove the MbCompression without any problem.

Right now if you disable MbCompression, the website cannot find the files.


On Mon, Nov 17, 2008 at 10:39 AM, Miron <notifications@codeplex.com> wrote:

From: Miron

I got the attached code.

I posted a bug fix to the source control at http://www.codeplex.com/MbCompression

Let me know if it solved your problem.


Regards,

Miron

http://blog.mironabramson.com



cewongq wrote:

From: cewongq

Sure, I tried replaying your email, but I´m not sure if the attached file was sent.

Did you receive it?

Read the full discussion online.

To add a post to this discussion, reply to this email (MbCompression@discussions.codeplex.com)

To start a new discussion for this project, email MbCompression@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Nov 17, 2008 at 4:33 PM
For example, if you have :
<script type="text/javascript" src="Scripts/ajax.js"></script>
<script type="text/javascript" src="Scripts/common.js"></script>

you´ll have to change the two lines into:
<script type="text/javascript" src="Scripts/ajax.js,common.js"></script>


Instead you can use a tag like:
<!-- FilesGroup -->
<script type="text/javascript" src="Scripts/ajax.js"></script>
<script type="text/javascript" src="Scripts/common.js"></script>
<!-- /FilesGroup -->

on this way it is transparent to have or not to have MbCompressor

:D
Coordinator
Nov 17, 2008 at 4:47 PM

Ahh, got you.

Very nice and useful idea.

When I will have time, I will check the best way to implement it.

If you have an idea of best way to implement it - feel free to post it to me.

Also, if you have another ideas, I will be glad to hear.


P.B.

Did my fix helped you with the service problem ?


Miron



cewongq wrote:

From: cewongq

For example, if you have :



you´ll have to change the two lines into:



Instead you can use a tag like:





on this way it is transparent to have or not to have MbCompressor

:D
Nov 17, 2008 at 5:02 PM
Yes it worked perfect...

But, it compress aspx results, right? Does it compress webservices results??

I´m an anoying user.... :D
Nov 17, 2008 at 7:04 PM
Another problem...

When minimizing css, all the 

background: url(http://www.site.com/img/background.gif)

are changed to:

background: url(http:

It is truncated...


I tried to identify the problem, but it takes more than I expected....

Coordinator
Nov 23, 2008 at 4:30 PM
@cewong,
The solution is very simple, just use: background: url('http://www.site.com/img/background.gif') instead of:  background: url(http://www.site.com/img/background.gif)
(use Quotation marks)  and you are ready to go :)

Miron
http://blog.mironabramson.com